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Introduction 
 
Most high-level sporting bodies provide online mechanisms for recording results and publishing a ladder for 

a teams-based competition. However, in most cases an affiliated club must enter registration details for 

each player involved in a team. For many clubs the maintenance of these records is too cumbersome. 

 

The software provided here is a low maintenance and efficient way of recording scores and producing a 

ladder. It has options to cater for many different sports. It runs on a Microsoft Windows computer. 

 

The Teams Manager computer software is Microsoft Windows based and will do the following: 

• automatically create a draw, based on the number of teams and round dates entered. 

• record the team scores and calculate the ladder.  

• enable the names of team players to be recorded (however this is optional). 

• allow viewing and printing of teams, draws, results and ladder. 

• generate score sheets (for some competition types). 

• keep track of multiple competitions. 

• Create html files for publishing to the web. 

Individual scores for sets or rubbers are not recorded. Only the team scores are recorded. 

 

Installing the Software 

The installation program will be provided on a memory stick or downloaded from the internet. It is called 

TeamsManagerSetup.exe. Run the program to install it on your Microsoft Windows computer.  

The program is personalised to your club and may not be transferred to any other group or individual. 

Updates may be available from time-to-time. These are generally provided as the actual program file 

TeamsManager.exe which must be copied to the Teams Manager folder (replacing the existing file). 

Starting the program 

Start the program in the usual way by clicking a shortcut icon. Shortcut icons are usually found in one or 

more of the following places: 

• On the Desktop (this one requires a double-click) 

• On the Taskbar 

• On the Start Menu 

• In the All Apps section of the Start Menu – in the Teams Manager folder. 

 

The program’s User Interface is shown on the next page. The program window can be re-sized to suit your 

working habits. 
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The User Interface 

 

 
 
  

Menu Bar 

Tool Bar 

Club Name 

Competition Name 

Club Logo 

Status Bar 

Copyright & 
Version Information 
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Setting up a New Competition – Four Steps 

1. File > New Competition  
Select New Competition from the File menu as show below. The New Competition window will then be 

displayed. 

 

Enter a Competition Name.  

 

Note that the word Competition 

is appended to this name on all 

reports. Hence, don’t use the 

word Competition here. 

For best practice, use the year at the beginning of the competition name. The name you provide here is 

used as a folder name on the computer, and for report headings. However, the report headings name 

may be changed later in the Preferences. 

Using the year at the start of the competition name helps to keep the names in chronological order in 

the list of competitions, and to streamline the management and archiving of old competitions. 

The Start Date defines the first day on the calendar which is used to select the dates for each round of 

the competition. 

Click Save when done. The new competition will open with a message that teams can now be added. 

 
2. Enter Team Names 

Teams (and optionally, players) can be imported from a CSV file. Or they can be entered manually from 

the Edit menu options – Add Team names and Add Player Names. 

 

The CSV option is an easy one to use if adding both Teams and Players. CSV files can be created using 

Microsoft Excel (or equivalent software). See the section “CSV files” on page 9. 

 

After creating a CSV file, select:  File > Import Teams from the menu bar, and then select your CSV file 

using the File Explorer window that pops up. 

 
3. Enter the Round Dates: Tools > Round Dates (see page 8 for details). 

a. Once the round dates are saved the DRAW is automatically created. 

 

4. Change the preferences to suit the scoring rules for your competition. Tools > Preferences 

b. See page 6 for details about the preferences. 

 

Once the above steps have been completed you are ready to start adding results to the competition. 
 

Once results have been entered you cannot change the scoring method, nor can you add or remove 

teams. Make sure these items are correct before you start entering results. 
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Events 

 
There is an option to add EVENTS to the schedule via Tools > Events Dates. These events will appear within 
the Draw in chronological order. You might include events such as Club Championships, Social Day, etc. 
 
 

Open and Close a Competition 

 

Following the completion of each round you will 

need to enter the results. The first step is to open 

the competition. 

 

This is accomplished by clicking the OPEN option 

on the toolbar and selecting the required 

competition from the drop-down list. 

 

The picture at right shows three competitions to 

choose from.  

 

 

 When a competition is open, you can close it by clicking the CLOSE 

option on the toolbar (shown at the right), or by exiting the program.  

 

Use the EXIT button to exit the program or click the X in the top right 

corner. 

 

 

Viewing and Printing 
 
 
Options are available for viewing the Teams, Draws, Results 
and the Ladder. You can access them from the Toolbar icons 
as seen to the right. 
 
 
Each of the view windows has a printer icon. Click the printer icon 
to initiate a printed output of the page. In the case of the Ladder, 
you have the option to print in landscape or portrait. The portrait 
option will use less of the page. 
 
Note that the View options are also available from the View menu 
on the Menu Bar. 
 
 
If you are only viewing (and not printing) you can click the icon once to view the page and click the icon 
again (without moving the pointer off the icon) to close the page. Otherwise, click the X on the top right 
corner of the page to close it. 
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The Ladder 

 
 

The percentage (calculated from For / Against) is used to determine the order of teams on the same 

number of ladder points. For sports that use the Sets & Games (or Rubbers and Games) scoring, the for and 

against use games won and games against. 

 

 

Entering Results 
 
At the completion of each round you will enter the results. For this, click the Add Results 
icon on the toolbar.  
 
Depending on the settings chosen in preferences, you may be entering: 

Two items, such as Sets and games, or one item, such as Games or Points, or Goals. 
 
For fast entry of scores, the cursor will automatically move to the next field after entering a specified 

number of digits (determined by a setting in the Preferences). There is an override on the score entry page 

if you need to enter more digits than the specified number. You can also turn this feature OFF in the 

preferences. 

 

If you enter less digits than the specified number then you can forward to the next field by pressing the 

Enter key, or the Tab key, or mouse click into the next field. 

 

 
Click the SAVE button when all scores have been entered. At this point the LADDER is updated, and a 
backup of the data file is created in the Backup folder. 
 
 
 
What if a score has been entered incorrectly? 
 
You can go back and change the results. In this case you 
click the Add Results icon and change the round number to 
round where the result is incorrect.  
(Press The TAB key or the ENTER key after changing the round 

number). 
The previously entered results will now appear.  
 
Correct the results as required and click SAVE. 
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What if a round is cancelled? 

 

On the Enter Results page click Skip Round on the menu 

bar.  

 

Note that you can only skip the current round. 

 

If you skip a round inadvertently, you can still select 

the round and add results. A skipped round, if played at a later time, can still have the results 

entered at that later time. 

 

Preferences 

 
Preferences is where you can tailor the system to suit the rules of your competition. Access the preferences 
from the Tools menu. There are 6 pages in the preferences each being accessed by clicking the Tabs across 
the top.  

 
The Competition Page 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Here you can change the Month/Year for the Calendar start date. The Scoring Category Determines the 
type of scores that you will enter. 
 
The first two categories provide the option of selecting a winner by: 

Games Only, or Sets then Games, or Games then Sets. 
 
These two categories are identical except for the terminology (Sets vs Rubbers). 
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The Scoring Page 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Here you can set the way a winner is determined and the points to be allocated for a win, draw, etc. 
 
If the competition has an odd number of teams, there will be a bye in each round. You can specify whether 
or not the bye team is allocated winning points (and games). 
 
 
 
The Competition Name Page 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Here you will see the competition name you entered when creating the competition. You can change the 
name, which changes the name on screen and printed reports. 
 
However, the competition folder name will not change from the original. 
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The Folders Page 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Media Folder is a folder where the results from the current round are saved when using the Media 
Report option in the Reports menu. If you select the same file name for multiple competitions, all results 
will be saved in that one file. This is handy for sending weekly results to the media. 
 
The HTML Folder is where web-based html files are saved when you select the HTML icon on the toolbar. 
You should not change the default location unless you have a good reason.  
 
If you plan to publish the results on the web you also need CSS files to accompany these html files. The 
required CSS files can be found in the CSS folder. 
 
The website address entered on this page is opened when you click the Website icon on the toolbar. You 
could enter your club’s website address here for quick access to your website. 
 
 
The Printing Page 

 
 
The left and right margins are set here for 
the printing of score sheets.  
 
The right margin of 75 leaves a blank area on 
the right side of the score sheet for the 
clipboard clip. 
 
The margins may be temporarily altered at 
the time of printing a score sheet. 
 
Note that score sheets are printed from the 
Score Sheets option on the menu bar. 
Currently there are score sheets for tennis & 
table tennis. 
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The Data Entry Page 
 
These settings apply to the Add 
results page.  
 
 
The maximum score is to 
provide a warning if you 
inadvertently enter a score 
greater than this value. Set it to 
a large value if it is not relevant 
to you. 
 
 
 
 
 
 
 
 
 
 

 
The auto advance settings allow the cursor to automatically move from one field to the next after entering 
the specified number of digits. In the example above it is one digit in the case of Rubbers, and two digits in 
the case of Games. 
 
Depending on your scoring type, these settings may be best turned off (by unchecking the check boxes). 
 

 
Once all settings have been changed, click the OK button.  
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Round Dates  
 
At the start of a new competition the round dates must be selected. This is done from Tools > Round Dates. 

You will see a calendar, as shown below, starting at the month you selected previously when creating the 

competition, or may have changed in the Preferences. 

 

 
 
To select a date, click on it with the mouse. The date will then be bolded. Click on the date again to remove 
a date (not bolded). 

On the calendar above, dates have been selected on Wednesdays from June 1 to August 24 with a few gaps 
in between. On the menu bar, in red, you can also see the number of rounds selected (10 in this case). 

When finished selecting dates, click the SAVE option on the menu bar. At this point the DRAW will be 
created (or modified). 

On the status bar of the main window (bottom left corner) you can see how many rounds have been 
scheduled. Here you will also see the number of the last round completed and the number of teams in the 
competition. 

 

Once you have started entering round scores you won’t be able to add or remove dates prior to 
the last round played. 
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Backing up Your Data 
 

Quick Backup/Restore 

There is an option on the File menu to perform a Quick Backup. This will create a copy of the 
selected competition file. You must provide a name for the backup copy. 
 
Since an automatic backup is performed when you Save results, this option will have little use. 
 
If you need to return to a previous state, then you can perform a Quick Restore. Here you will 
select one of the backup files and it will overwrite the current competition file. 
 
A restore would only be necessary if the current data file became corrupt. The backup files are 
stored in a sub-folder called Backup under the competition folder. 
 

Automatic Backup 

An automatic backup is created every time you click SAVE on the results entry screen. The file 
name has the format: Comp-xx-2022-08-04-213726.mdb where xx is the round number and it is 
followed by date and time. 
 

CSV Files 

The easiest way to setup your team names (and player names if you require them) for a new 
competition is via a CSV(comma delimited) file. The CSV file can be imported into the competition. 
 
A CSV file can be created with Microsoft Excel (or equivalent software). Instead of saving the file as 
a normal spreadsheet, save it as a CSV(Comma Delimited) file. 
 
You can do this in Excel via File > Save As and select options as shown below. Then click the Save 
button. 

 
 
The spreadsheet must be constructed as follows: 

The team names must be in column 1 and have an asterisk “*” in front. 
 
Player names: First name in column 1, Surname in column 2 
Player names must immediately follow their team’s name as shown at left. 
 
After importing the names, you can make 
changes via the Edit menu. 
 
To the right is a sample team list with teams 
only. 
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Managing Competition Folders 

You will need to consider how to manager each competition from one 
season to the next. 

When you click OPEN on the toolbar all current competitions will show in the 
list as seen in the diagram to the right. These are the competitions with a 
presence in the DBases folder (refer to the folder structure on page 11). 

To keep the list in chronological order you must use the year at the start of 
the competition name as per the example shown to the right.  

To keep the list manageable you will need to clear out old competitions from 
time-to-time. 

For clearing out old competitions, you have the following options:  

• Use the Archive option on the File menu (see picture at right) to 
move them to the Archive folder.  

This is the preferred method. The Archive folder is created the first 
time you run the program. 

• Delete the competition folder (out of the DBases folder). 

• Manually move the competition folder to another folder on your 
computer (or USB memory). 

 

Publishing to a Website 

The program can create html files suitable for publishing on a website. The HTML icon on the toolbar is 
used to create the files. There are four files created, one each for Teams, Draws, Results and Ladder. 

The web server folders diagram on page 12 shows how these files can be structured on a website. The CSS 
folder shown in the diagram can be found in the Teams Manager folder on your computer. 

NOTE: Most of the free website builder platforms, such as Wix, Weebly, WordPress, GoDaddy, etc, will not 
allow you to copy files to your website. In such cases you may need to find a third party to host the files and 
link to them from your website. 

 

Score Sheets 

Score sheets have been developed for some sports. They can be found on the Score Sheets menu bar 
option. They are currently available for tennis and table tennis. Others can be developed if required. 

For the current score sheets, a blank score sheet can be printed without opening a competition. A second 
option allows the score sheet to be printed with round date and team names; the competition must be 
open prior to selecting this option. 
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© Technavac 15 

 

Future Development 

 
Any problems discovered in the software will be dealt with as a matter of urgency. If you do encounter a 
problem, try to document exactly what you were doing at the time. 
 
If there are sports where the scoring is not catered for, I can add them as required. 
 
Additional scoring sheets may be added if requested. 
 
 

Contact Details 

 
You can make contact via: 
 

The Contact Us page on our website: http://technavac.com.au  
Email: admin@technavac.com.au 
Mobile: 0401 916 667 
 

http://technavac.com.au/
mailto:admin@technavac.com.au

